Author Topic: Regression inside latest version of BASS_FX (2.4.4.0)  (Read 6858 times)

0 Members and 1 Guest are viewing this topic.

Offline nadia

  • Posts: 3
    • View Profile
Regression inside latest version of BASS_FX (2.4.4.0)
« on: April 17, 2009, 06:52:47 PM »
Hello  ;D

I've found a regression inside latest version of BASS_FX (2.4.4.0).
It seems that the BASS_ChannelGetPosition and BASS_ChannelSetPosition functions are no more accurate as they where in previous versions when dealing with a stream resampled through the BASS_FX_TempoCreate function.

In order to demonstrate the issue I've made a modification to the Tempo.exe project included with the BASS_FX package (uploaded into http://www.megaupload.com/?d=JFBX4A8U); inside this sample I've added a routine which displays (under the trackbar position) the position in bytes during playback respect to the overall stream size in bytes; I've also removed the BASS_SAMPLE_LOOP flag from the BASS_FX_TempoCreate function call in order to better display the problem.

As you will see, after loading the provided "short.wav" file (included inside the zip), playback will start and, when playback ends, the displayed position in bytes, returned by BASS_ChannelGetPosition is not the same value of the overall length in bytes returned by BASS_ChannelGetLength.

The BASS_ChannelSetPosition is not demonstrated in this sample but it seems to be affected also by a wrong positioning when called over the same stream resampled by BASS_FX_TempoCreate.

Any idea about the reason of this behavior?

Kind regards  ;D

Nadia
 

Offline (: JOBnik! :)

  • Administrator
  • *****
  • Posts: 44
  • Gender: Male
    • View Profile
    • (: JOBnik! :)
Re: Regression inside latest version of BASS_FX (2.4.4.0)
« Reply #1 on: April 24, 2009, 02:30:08 PM »
Hi ;D

This issue is fixed on version 2.4.4.1 :)
Please read all about it on BASS forum:
http://www.un4seen.com/forum/?topic=9711.0
Have fun!
8) JOBnik! 8)

Offline nadia

  • Posts: 3
    • View Profile
Re: Regression inside latest version of BASS_FX (2.4.4.0)
« Reply #2 on: April 24, 2009, 03:48:15 PM »
Hi ;D

This issue is fixed on version 2.4.4.1 :)
Please read all about it on BASS forum:
http://www.un4seen.com/forum/?topic=9711.0

Hi  ;D

Thanks and sorry for double posting: now it's all OK  ;D

Kind Regards  ;D

Nadia