Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - nadia

Pages: [1]
1
Bugs / Re: Regression inside latest version of BASS_FX (2.4.4.0)
« on: April 24, 2009, 03:48:15 PM »
Hi ;D

This issue is fixed on version 2.4.4.1 :)
Please read all about it on BASS forum:
http://www.un4seen.com/forum/?topic=9711.0

Hi  ;D

Thanks and sorry for double posting: now it's all OK  ;D

Kind Regards  ;D

Nadia

2
Bugs / Regression inside latest version of BASS_FX (2.4.4.0)
« on: April 17, 2009, 06:52:47 PM »
Hello  ;D

I've found a regression inside latest version of BASS_FX (2.4.4.0).
It seems that the BASS_ChannelGetPosition and BASS_ChannelSetPosition functions are no more accurate as they where in previous versions when dealing with a stream resampled through the BASS_FX_TempoCreate function.

In order to demonstrate the issue I've made a modification to the Tempo.exe project included with the BASS_FX package (uploaded into http://www.megaupload.com/?d=JFBX4A8U); inside this sample I've added a routine which displays (under the trackbar position) the position in bytes during playback respect to the overall stream size in bytes; I've also removed the BASS_SAMPLE_LOOP flag from the BASS_FX_TempoCreate function call in order to better display the problem.

As you will see, after loading the provided "short.wav" file (included inside the zip), playback will start and, when playback ends, the displayed position in bytes, returned by BASS_ChannelGetPosition is not the same value of the overall length in bytes returned by BASS_ChannelGetLength.

The BASS_ChannelSetPosition is not demonstrated in this sample but it seems to be affected also by a wrong positioning when called over the same stream resampled by BASS_FX_TempoCreate.

Any idea about the reason of this behavior?

Kind regards  ;D

Nadia
 

3
BASS_FX / Problem with BASS_FX and tempo resampling
« on: February 24, 2009, 11:16:59 AM »
Hi   ;D
I've found a strange problem when playing the wav file below using a stream resampled by BASS_FX in order to manage tempo change: the problem can be easily reproduced using the "tempo.exe" sample included inside the BASS_FX zip file.
http://www.un4seen.com/forum/?action=dlattach;topic=9501.0;attach=632

This WAV file contains a sequence of 4 drum beats: if you play it with Bass or WMP or Winamp you will clearly hear that all of the 4 beats have the same energy: if you play the same file using the "tempo.exe" sample of BASS_FX you will hear that the 3rd beat has less energy and, by the way, it seems that the first 2 beats have an energy higher than the original: can this glitch be corrected in some way? It's quite an urgent matter  :'(

Kind Regards  ;D

Nadia

Pages: [1]